Cisco Router VLAN yapılandırılması ve Yönlendirilmesi

Merhaba Arkadaşlar , Bu günkü konumuz Cisco Router VLAN yapılandırılması ve Yönlendirilmesi nasıl yapılır ? mantığı nelerdir ?

VLAN yani Virtual Local Area Network switchler üzerinde yapılan mantıksal bir gruplama şeklidir. VLAN oluştururken bilgisayarların fiziksel durumlarına, yerlerine bakmak yerine işlevine veya departmanına veya bulunduğu kata göre düzenlemeler yapılır.

Örneğin ; Bir network’te Muhasebe bölümü bir VLAN’da Bilgi Teknolojileri başka bir VLAN’da bulundurulabilir ve bu sayede 2 departman arasında ki iletişim istenilirse engellenebilir.

VLAN oluşturmak komutlardan bağımsız olarak anlatmak gerekirse iki adımdan oluşur.
1. VLAN Oluşturulur
2. Portlar VLAN’ lara üye edilirler.

Örnek Komut şöyledir ;

Switch#configure terminal
Switch(config)#vlan 2
Switch(config-vlan)#name pazarlama
Switch(config)#vlan 3
Switch(config-vlan)#name insan_kaynaklari
Switch(config)#vlan 4
Switch(config-vlan)#name teknik_destek

NOT: VLAN1 silinemez, değiştirilemez veya yeniden adlandırılamaz.
VLAN’ lar oluşturulduktan sonra artık ikinci adıma geçebiliriz. Bu adımda Switch portları
VLAN’lar ile eşleştirilecek. Tabi burada VLAN üyeliğinin Static yada Dinamic olduğu da
belirtiliyor.

 

Switch#configure terminal
Switch(config)#interface Ethernet 0/2
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport Access vlan 2
Switch(config-if)#exit
Switch(config)#interface Ethernet 0/3
Switch(config-if)#switchport mode acces
Switch(config-if)# switchport Access vlan 3
Switch(config-if)#exit
Switch(config)#interface Ethernet 0/4
Switch(config-if)#switchport mode acces
Switch(config-if)# switchport Access vlan 4
Switch(config-if)#exit
Switch(config)#

Trunk ve Trunk Konfigürasyonu
Trunk bağlantılar cihazlar arasında VLAN’ları taşımak amacıyla kullanılırlar ve VLANların tümünü
ya da bir kısmını taşımak üzere biçimlendirilebilirler. Sadece Fast ya da Gigabit Ethernet üzerinde
desteği vardır. Cisco switch’ler trunk bağlantı üzerindeki VLAN’ları tanımak için iki ayrı yöntem
kullanır: ISL ve IEEE802.1q.

Switch – Switch,  Switch-Router arasındaki bağlantılarda portu trank yapmalıyız.

Layer3 Swtich ve ya Router olabilir.

 

 

Switch#configure terminal
Switch(config)#interface fastethernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#exit

VLAN’lar Arasında Yönlendirme
Bir VLAN’a bağlı cihazlar kendi aralarında iletişim kurabilir, broadcast’lerini gönderebilirler.
VLAN’ların network’ü fiziksel olarak böldükleri varsayıldığı için VLAN’lar arasında cihazların
iletişim kurabilmesi ancak 3. katman bir cihaza yardımıyla olacaktır.
Bu durumda yapılacak bir router üzerinde her VLAN için bir bağlantı eklemek ve Router üzerinde
gerekli konfigürasyonları yaparak iletişimi sağlamaktır.

 

Böyle bir topoloji üzerinde çalıştığımızı varsayalım:

Switch#configure terminal
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport acces vlan 2
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/3
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport acces vlan 2
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/4
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport acces vlan 3
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/5
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport acces vlan 3
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/6
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport acces vlan 4
Switch(config-if)#exit
Switch(config)#interface fastethernet 0/5
Switch(config-if)#switchport mode acces
Switch(config-if)#switchport acces vlan 4
Switch(config-if)#exi

Şimdi sıra Router üzerinde gerekli konfigürasyonu yapmaya geldi.
Bunun için Router’ın Fastethernet 0/0 interface’i altında sanal interface’ler oluşturmak, bu sanal
interfacelerin adreslerini atamak ve encapsulation standardını belirlemek gerekir.
NOT: Gerçek Interface’in ip adresi olmamalı.

Router#configure terminal
Router(config)#interface fastethernet 0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
Router(config-if)#interface fastethernet 0/0.2
Router(config-subif)#encapsulation dot1q 2
Router(config-subif)#ip address {ip adresi} {subnet maskı}
Router(config-subif)#exit
Router(config-if)#interface fastethernet 0/0.3
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address {ip adresi} {subnet maskı} 
Router(config-subif)#exit
Router(config-if)#interface fastethernet 0/0.4
Router(config-subif)#encapsulation dot1q 4
Router(config-subif)#ip address {ip adresi} {subnet maskı} 
Router(config-subif)#exit


Konumuz şimdilik bu kadar bir sonraki makalemizde görüşmek dileğiyle 🙂

Diğer konularımıza göz atmanızı öneririm ;

Cisco Router’a Enable şifresi koymak

Cisco cihaza isim vermek

Cisco ve DELL switch SSH açmak

 

 

Ömer Sorguç

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Pin It on Pinterest